Anfängerfragen zu NC-Easy

  • Hallo zusammen,


    es ist schon eine ganze Zeit her, daß ich meine BF20L mit NC-Easy zum Laufen gebracht habe.
    Jetzt bin ich endlich dazu gekommen, mich mal etwas intensiver damit zu beschäftigen - leider sind bei mir bei Nutzung von NC-Easy einige Fragen aufgetaucht die es mir praktisch unmöglich machen mal endlich einen Fräsversuch zu starten.
    Vielleicht hat hier jemand die Kenntnisse und Ausdauer mit da etwas unter die Arme zu greifen.


    Hintergrund :
    Die BF20L wird angetrieben mit dem passenden Controller VI von Optimum.
    Endschalter sind auf der X und Y-Achse (Kein Endschalter auf Z !).
    Vorher eingesetzt wurde MACH3, mit durchaus brauchbaren Ergebnissen, nur war mir das ganze zu kompliziert und noch dazu habe ich keine Parallelportkarte gefunden, bei der die Kombination "Neuer Rechner" mit "BF20L" zum laufen zu bringen war.


    Fragen :
    1.) Nullpunkt. Von Mach3 bin ich es gewohnt, einen relativen Nullpunkt am Werkstück manuell anzufahren, die Achsen zu nullen und loszufräsen.
    Bei NcEasy jedoch funktioniert dies offensichtlich nicht. Immer und immer wieder will die Fräse den absoluten Nullpunkt anfahren, verschiebt diesen, fräst nicht los, weil irgendwas mit den absoluten Werten nicht stimmt usw. usw.
    Alles, was ich will ist doch : Manuell anfahren, Nullen, Losfräsen. Was ist hier die beste Vorgehensweise ? Den Arbeitsbereich überwache ich schon selber. (Meine Teile sind nur wenige Zentimeter in X und Y und Z ....


    2.) Referenzfahrten. Begreif ich nicht. Meine Endchalter an X und Y haben jeweils zwei Positionen an denen sie ausgelöst werden. Ich hatte mir jetzt vorgsetellt, daß bei einer Referenzfahrt auch die jeweiligen Max und Min-Positionen JE ACHSE angefahren werden ... aber nix ! Bildet NcEasy hier die absolute Position ausschließlich aus dem einen angefahrenen Endpunkt und den manuell eingegebenen Maschinenparametern/Verfahrwegen ?


    3.) Dateiimport. Es ist zwar geschrieben daß NcEasy auch .ai-Dateien verarbeiten kann - nur merken tue ich davon im Moment irgendwie noch nichts. Öffne ich eine auf meinem Mac in CS2 erstellte (2D) Illustrator-Datei, bekomme ich als Importergebnis nur einen Strich. Nehme ich eine DXF-Datei die ich in "ProfiCad 6" erstellt habe, ist das ergebnis eine winnnzige Kontur innerhalb von NcEasy. Aus einer 6cm langen Tasche wird in NcEasy eine vielleicht 4mm lange. Da kann ich an den Importoptionen hinsichtlich 1mil, 1/10mm, 1/1000 mil usw. rumfummeln wie ich will - es bleibt so klein.


    Wenn mir insbesondere bei den Punkten 1 und 2 jemand auf die Sprünge helfen könnte ... das wäre klasse ... damit ich mal weiterkomme.


    Gruß, JNR

  • Hallo JNR, wie auch immer du heissen magst.
    Woher kommst Du?


    Ich nutze NC-Easy seit ca. einem halben Jahre ohne deine Probleme.
    Allerdings habe ich an meiner Maschine an allen Achsen Reverenzschalter dran.
    NC-Easy fährt nacheinander einen Reverenzschalter je Achse an und weiss somit genau wo die Maschine gerade steht, danach ist alles ganz Easy.
    Die Software braucht nur einen Reverenzschalter je Achse um zu wissen wo die Maschine steht, nicht beide.
    Es wäre auch für Dich das Sinnvollste den 3 Reverenzschalter nachzurüsten.
    Dann brauchst Du im Grunde genommen keine Endschalter, da NC-Easy den Arbeitsbereich perfekt überwacht.


    Unter Einstellungen -> Optionen -> Meldungen kannst du den Haken bei "Prüfen ob Reverenzfahrt ausgeführt" entfernen, dann sollte NC-Easy keine Reverenzfahrt mehr verlangen, aber ich halte das für nicht sinnvoll, Reverenzfahrt wäre besser.


    Nach der Reverenzfahrt kannst Du entweder deine Materialposition manuell eingeben oder per Antasten/Ankratzen oder sogar per Taster anfahren und einmessen.
    Wenn du deine Positionen eingegeben und dein Material in den Bearbetungsbereich liegt ist der Rest eigentlich kein Problem mehr.


    ai hab ichj bisher nicht als Datei ausprobiert, bisher ging alles per dxf oder plt.
    Gib evtl. bei den Importoptionen unter frei definierbar den Wert1 ein, das müsste gehen, da deine Datei um den Faktor 25 zu klein ist.
    Viel Erfolg und berichte ob es geklappt hat.
    Gruß
    Ingo

  • Hallo Ingo,


    danke für Deine Statements.
    Schon allein, daß Du "Referenzschalter" genannt hast, bringt mich in der Geschichte schon weiter. Das, was ich da an meiner Maschine habe, sind also eher "Referenzschalter" und keine "Endschalter" - irgendwie hatte ich die Dinger von der Funktion her eben eher als "Endchalter" im Kopf. OK, also einen Referenzschalter pro Achse - die Arbeitsraumüberwachung wird dann anhand der eingegebenen Verfahrwege interpoliert - soweit verstanden. Mal sehen, ob ich den für die Z-Achse noch irgendwie besorgen kann - meiner ist defekt.


    Wenn ich mir jetzt meinen Arbeitsbereich in 2D im NcEasy anschaue, dann muß doch dieser durch die Referenzfahrt festgelegte Nullpunkt der Maschine genau unten links in der Ecke der angezeigten Arbeitsfläche liegen, richtig ? (Ich habe inzwischen soviel herumgefummelt, daß der weit ausserhalb dieser Fläche liegt ... ohne die Hand auf dem Not-Aus mache ich also inzwischen nichts mehr !) ;)
    Wenn ich jetzt das Werkstück anfahre ... dann lege ich doch auf diesem meinen zweiten, den relativen, Nullpunkt fest - richtig ?
    Mein Problem : Das Werkstück sitzt natürlich irgendwo mittendrin auf der Arbeitsfläche. Ich schaffe es um´s Verr..... nicht, dieses Werkstück 1:1 dort im NcEasy auf der Arbeitsfläche anzeigen zu lassen, wo es in Wirklichkeit auch ist !


    Wie ist hier der bevorzugte Weg, um das hinzubekommen ?


    Danke im Voraus für Hilfe zu meinem Problem,


    Gruß, Jan (aus Hamburg)

  • Hallo Wusel,


    ich werde gleich morgen mal schauen, wie ich die bisherigen, neuen Erkenntnisse umsetzen kann.
    Melde mich dann pronto, sobald ich mehr weiss.


    Eine Frage noch zum "Ende":
    Alle Werte, die die Fräsbahnen beschreiben (also Eintauchtiefe, Fahren nach x und Y) sind immer relativ im Bezug auf den frei setzbaren Werkstücknullpunkt zu sehen - richtig ?
    Ausserdem noch : Wird bei .dxf-Daten irgendeine Koordinate an das NcEasy mitgegeben ? Anders gefragt : Innerhalb des "ProfiCAD" kann ich das Werkstück praktisch frei im Raum, oder aber im Bezug auf das dortige Koordinatensystem mit X und Y zeichnen. Kann es sein, daß ich einfach nur dort Mist gebaut habe, weil ich nicht genau bei 0,0 die unterle linke Ecke hatte ?


    Jan

  • Hallo Jan,
    Schade, Hamburg ist für "mal eben hinfahren" doch etwas weit weg.
    Wenn Du ohne Reverenzschalter arbeitest hast du eben das Problem, das deine Software nicht weiss wo deine Maschine stehgt, also kannst Du auch keinen exakten Punkt eingeben wo dein Material liegt.
    Das hast Du bisher durch anfahren des Materials behoben und du konntest fräsen, aber deine Software wusste noch immer nicht wo deine Maschine nun wirklich arbeitet, da dieser Punkt wohl irgendwo im Nirvana war.
    Du hattest doch oben irgendwo geschrieben das du 2 Schalter je Achse hast, oder?
    Kannst Du nicht einen Schalter vorübergehend an Z anbauen?
    Du mmußt dann nur sehen das du den demontierten Anschluß elektrisch wieder richtig anklemmst, also wenn COM und MC angeschlossen sind die beiden Drähte dieses Schalters verbinden, wenn COM und NO angeschlossen sind diese beiden Drähte nicht verbinden und gegebeinander isolieren (Isoband, zur Not Tesafilm).
    Den ausgebauten Schalter kannst du dann ggf. gegen den defekten Schalter an der Z-Achse tauschen und somit schon mal deine Maschine komplett Reverenzfahren.
    Wenn dann noch die Wege korrekt eingegeben sind (danach ausprobieren) sollte auch das positionieren des Werkstücks kein Problem mehr darstellen.
    Der Reverenzpunkt muß nicht zwangsläufig unten links in der Ecke liegen, wenn es Dir besser passt kannst Du ihn auch oben link oder oben rechts oder unten rechts in die Ecke setzen, das ist per Mausklick in NC-Easy einstellbar. Einstellungen -> Maschinenparameter -> Achsen -> Reverenzpunkt.
    Bei Maschinen mit fahrenden Tisch ist es meist ganz angenehm wenn der Reverenzpukt oben ist, da so gleich der Tisch freiliegt zum bestücken und man sich 2 Leerfahrten spart.


    Das dein Werkstück nicht da angezeigt wird wo es liegt liegt eben daran das deine Software nicht weiss wo die Maschine steht.
    Beu deine Reverenzschalter an und du lernst NC-Easy lieben, versprochen.
    Wir können gerne mal telefonieren, nur jetzt macht es keinen Sinn, da ich kaum noch Stimme habe, verdammte Erkältung.
    Wenn Du willst könnten wir morgen früh (ca. 10Uhr) telefonieren, wenn du willst PN an mich.
    Gruß
    Ingo

  • Wenn man die Zechnung mit Datei -> Einfügen öffnet und unter "Datei unter einer Position hinzufügen" "Original Position" anhakt wird es auf die Position gesetzt die in deiner Datei angegeben ist.

  • Hi Wusel


    Wenn Du in Corel 11 eine eps Datei machst kommt eine bessere Qualität an.


    Versuchs mal. Nur in X3 ist ein Bug das die Farben der einzelnen Linien nicht mehr stimmen.


    Gruß Amadeus 8)8)8)

    . Ein Kluger bemerkt alles,
    ein Dummer macht über alles seine Bemerkungen.
    Heinrich Heine

  • Hallo Jungs,


    sodele - ich hab grad mal wieder ne Stunde vergebens versucht für meine Maschine passende Grundeinstellungen hinzubekommen.
    Ich denke mittlerweile aber weniger, daß es es an der Technik liegt - ich scheine da eher nen Knoten im Hirn zu haben.
    Als erläuterung habe ich euch die nachfolgende Bilddatei zusammengestellt, damit ich das Problem besser verdeutlichen kann.


    Die Positionen meiner Referenzschalter und der auslösenden Magneten habe ich entsprechend farblich kenntlich gemacht.


    Mein Ziel war : Den Maschinennullpunkt (also diesen orangeblauen Babbel), wie in der Zeichnung angezeigt, oben links auf die Ecke der Arbeitsfläche zu bekommen.
    Ich bin also nochmal durch den Einrichtungsassistenten durchgegangen. Den in den Maschinenparametern final gewählten Referenzpunkt könnt ihr ebenfalls in der Zeichnung sehen. Was mir dabei aufgefallen ist : Im Assistenten soll man ja die korrekten Fahrrichtungen der Achsen festlegen. Hab ich soweit auch gemacht - nur als ich dann die Referenzfahrt für Y startete, lief das Ding in die falsche Richtung. Liegt da vielleicht irgendwo der Hase im Pfeffer ?


    Ich bin also meine Referenzpunkte auf X und Y angefahren ... und habe in dem "Punkte"-Menü (das P mit dem kleinen roten Babbel in der Menüzeile) einen Nullpunkt
    gesetzt. In diesem Moment sah in der 2D-Arbeitsfläche alles soweit OK aus ... (wie in der Zeichnung). Ich dache, ich wäre endlich am Ziel ... nur ... wieso wird mir der Fräserstandort als "ausserhalb der Arbeitsfläche" angezeigt ? OK, denke ich - den muß ich also auch noch auf Null setzen. Flugs wieder die Referenzschalter angefahren. Oben alle Achsen XYZ auf Null gesetzt ... und ? Der Bunte Babbel da, steht nicht mehr oben links auf meiner Arbeitsfläche - nein, der sitzt jetzt genau dort, wo auch die Position des Fräsers in meiner Zeichnung ist - also ausserhalb der Arbeitsfläche. Wie geht denn sowas ?


    Ich hab dies jetzt mit x verschiedenen Versuchen und Vorgehensweisen ausprobiert. Andere Referenzpunkte (unten links) versucht. Immer dasselbe. Ich bekomme keinen definierten Maschinennullpunkt und den aktuellen "Aufenthaltsort" des Fräsers auf einen Punkt in der Arbeitsfläche ... nur ausserhalb. Langsam verzweifle ich !


    Bitte, schaut euch mal genau meine Bilderchen an. Habe ich hier einen Denkfehler in der Position der Schalter ? Den falschen Referenzpunktort in den Parametern ?
    Stimmt etwas mit den Richtungen meiner Achsen nicht ? Ich wähle den Referenzpunkt als "unten links", meine Achsen fahren meiner Meinung richtig rum - trotzdem fährt der Tisch auf Y in Richtung der Säule und nicht in Richtung des Endschalters ...


    Helfen würde mich vor allem, wenn mir jemand mal eine Schritt für Schritt Reihenfolge geben könnte, wann ich was wie anfahren und wann auf Null setzen muß, damit ich endlich zum Ergebnis komme - Danke !


    Fragen über Fragen.


    Jan

  • Schick mir mal ne PN, ach ja, geht ja nicht Profil nicht korrekt ausgefüllt.
    Schade, sonst hätten wir das evtl. am Telefon klären können...


    Normalerweise klappt das alles Problemlos wenn man einfach jeder einzelnen Anweisung aus dem Einrichtungsassistenten folgt.
    Etwas irritierend ist für mich das bei Maschinen mit fahrendem Tisch immer das sich die Achsen immer entgegen gesetzt der vermeindlichen Richtung bewegen.
    Also immer aus der Sicht vom Tisch auf den Fräser beobachten.
    Wenn der Fräser Richtung X+ (nach rechts) fahren soll muß also der Tisch nach links laufen, ebenso bei Y+ (nach oben) muß der Tisch nach vorne (unten) laufen.


    Bei deinem gewünschten Reverenzpunkt oben links muß dein Tisch also nach vorne rechts an die Reverenzschalter fahren damit der Fräser oben links an den Reverenzpunkt kommt.
    Wenn deiner Skizze folgend der Tisch in Reverenzposition steht (der Tisch also vorne und Rechts am Anschlag bzw Reverenzschalter) und der Fräser wird in Y am anderen Ende der Y Achse angezeigt läuft deine Y-Achse falsch herum. Kehre mal die Bewegungsrichtung von Y um.
    Reverenzposition nach bedarf, das musst du eben ausprobieren.
    Gruß
    Ingo

  • So, Kinnings - hab grad wieder ne Stunde an der Fräse verbracht (gefräst habe ich zwar noch immer nichts, aber das kommt später).
    Fazit für heute : Ich lerne ... und lerne ... und ... sie fährt ! (Das ist ja schon mal was, hm ?)


    Ich liste jetzt mal einige Gedanken/Erkenntnisse auf, die mir heute bei den versuchen gekommen sind. Sollten Stellen dabei sein, bei denen ihr euch an den Kopf fasst oder laut lachen wollt ... denkt bitte daran, daß ich gelernter Kaufmann bin - danke !) :D


    1.) Ist Null nun Null ?
    Der runde, bunte Babbel da oben in meinem Bild aus dem Post gestern, das ist ja garnicht der absolute Nullpunkt der Maschine - neee, das ist der Nullpunkt den ich mit "Nullpunkt setzen" setze ! (ach !) :whistling:
    Ich hatte den immer für den Maschinennullpunkt gehalten und mich deshalb immer so maßlos geärgert, wenn sich der verschob !
    Was allerdings immer noch Fragen aufwirft : Ich fahre bis an die Referenzschalter, nulle alles ... und trotzdem werde mir absolute Maschinenpositionen angezeigt, die eben nicht NULL sind !?!? Wenn mir noch irgendwer nen Tip geben kann, wie ich die endlich auf NULL bekomme, schließe ich ihn in mein Nachtgebet ein !


    2.) Scheiß auf die Arbeitsfläche !
    Also, mal ehrlich. Wenn ich den Referenzpunkt wie in meinem Bild zu sehen auf "oben links" setze, dann das Werkstück definiere ... dann die Zeichnung lade ... und als Positionierung nicht das Werkstück sondern den Nullpunkt angeboten bekomme mit den Optionen "mittig drauf" oder "mit unterer linker Ecke auf den Nullpunkt", dann habe ich irgendwas nicht richtig verstanden, oder es ist einfach krank. (Im Moment gehe ich von letzterem aus, bis mir einer sagt, wo ich falsch liege).
    Ich meine ... ich will die Zeichnung doch relativ zum Werkstück haben ... und nicht relativ zum Nullpunkt.
    Irgendwie erschliesst sich mir das nicht.
    Ergebnis : Siehe ersten Satz dieses zweiten Punktes


    3.) Start des Fräsvorganges !
    Ich clicke auf "Start" - es kommt ein Fenster mit den verschiedenen Werkzeugen usw. OK, ich clicke irgendwann nochmal auf Start und ... Also, mal ehrlich. Wer hat sich denn dieses blöde, modale Fenster da einfallen lassen ?
    Statt in dem Fenster zu bleiben, wird es geschlossen und stattdessen dieses modale ! (Also, ein autarkes Fenster, daß die Bedienung des Hauptfensters unterbindet, bis es geschlossen wird) Fenster eingeblendet, das noch nicht mal einen "Stop /Abbruch / Alles anhalten"-Knopf bietet ? Stattdessen ein güldenes Kreuz mit der Funktion "so langsam wie möglich" !


    Den hier von EAS mitlesenden : bitte ... ich gewöhne mich ja an vieles, aber dieses Ding geht garnicht !
    Warum bleibt das grosse Fenster mit den Werkzeugen und Einstellungen nicht geöffnet, das noch um den Speedregler und eine "STOP"-Funktion ergänzt wird ? Idealerweise auch mit einer optischen Hervorhebung, mit welchem Werkzeug die Maschine grade wie weit ist ?
    (Ich bin beruflich Softwaretester und sicherlich, was Frässoftware angeht, nicht betriebsblind ... hier sehe ich jedenfalls dringend Nachholbedarf !)


    4.) Das Laden einer .dxf-Datei !
    Auch das habe ich heute end-lich hinbekommen. Ich habe also ein Rechteck der Größe 20x5cm gezeichnet und importiert, allerdings wird die von mir im CAD definierte, korrekte Größe nur dann sauber importiert wenn ich beim Import auf "Eigene" und "1" gehe.
    Wobei ich mich immernoch frage, was "1" eigentlich bedeutet ? 1Meter ? 1Liter ? 1Sofa mit Springfedern ?
    Dieselbe Frage bei der möglichen Auswahl "1mil" ? Was bedeutet das ? 1Glas Milch ?
    Fragen über Fragen .... die mitgelieferte Anleitung schweigt sich hier leider aus.


    5.) Geschwindigkeiten !
    OK, es hat eine Weile gebraucht bis ich endlich dahintergestiegen bin, aber mittlerweile habe ich die Fräsgeschwindigeiten und auch die Eilgeschwindigkeiten soweit im Griff, daß ich sie einstellen kann.
    Was jedoch noch nicht läuft, ist das editieren der Geschwindigkeiten für die Referenzfahrt ! Bei mir kriecht die immer mit etwa 1mm/Sek. und das ist etwas nervig. Bestimmt bekomme ich das auch noch hin - wenn mir jemand hier aber schriftlich unter die Arme greifen möchte - nur zu !



    Subsummierend stelle ich fest : Joah, es wird langsam. Wenn ich allerdings zum Beispiel an die Einbindung eines Werkzeuglängensensors denke, der (so stelle ich mir das vor) bei jedem manuellen Werkzeugwechsel angefahren wird, das Werkzeug vermessen wird und dann dort weitermacht, wo er soll ... dann wird mir schon ein wenig mulmig.


    In den nächsten Tagen werde ich intensiv mit 2,0D Dingen beschäftigen. Ich denke das ist für den Anfang genau das Richtige. Als Material werde ich in Perimeterdämmung (so Hartstyroporplatten) rumfräsen, das bricht wenigstens keine Fräser ab und lässt sich super wegsaugen. Dann werde ich zu Epoxy- und CFK-Platten übergehen.


    Anregungen, Hilfestellungen, böse Kommentare oder Äusserungen " ... wie blöd ich bin" ... bitte posten - ich kann damit um !
    Meine Kritik gegenüber der Anwendung bitte ich konstruktiv aufzunehmen, denn genau so ist sie auch gemeint, auch wenn meine Beschreibungen bisweilen etwas "blumig" sind. :thumbup:


    Viele Grüße, Jan

  • Der runde, bunte Babbel da oben in meinem Bild aus dem Post gestern, das ist ja garnicht der absolute Nullpunkt der Maschine - neee, das ist der Nullpunkt den ich mit "Nullpunkt setzen" setze ! (ach !) :whistling:

    Der bunte (Orange/Blau) Babbel (woher du ihn auch immer hast) dürfte die Position sein in der du deine Reverenzschalter anfährst, richtig?
    Also wirst Du hier die Positionen X=0 und Y=Maximalwert deiner Y Achse haben, also erstmal weder den Absoluten noch den relativen Nullpunkt sondern deinen Punkt an dem Du die Reverenzmessung machst.

    Zitat

    Ich hatte den immer für den Maschinennullpunkt gehalten und mich deshalb immer so maßlos geärgert, wenn sich der verschob !

    Der Absolute Maschinen Nullpunkt ist der Punkt den die Mitte deines Fräsers unten links erreicht, also X=0, Y=0 Absolut

    Zitat

    Was allerdings immer noch Fragen aufwirft : Ich fahre bis an die Referenzschalter, nulle alles ... und trotzdem werde mir absolute Maschinenpositionen angezeigt, die eben nicht NULL sind !?!? Wenn mir noch irgendwer nen Tip geben kann, wie ich die endlich auf NULL bekomme, schließe ich ihn in mein Nachtgebet ein !


    NC-Easy zeigt dir aus Wunsch den Absoluten Nullpunnkt und den Relativen Nullpunkt an.
    Zu finden unter Ansicht -> Werkzeugleiste -> dort zum Anhaken Absolute Koordinatenleiste und Relativer Koordinatenleiste
    Bei der Absoluten wird die Werkzeugposition in Bezug auf dem Verfahrweg auf dem Tisch angegeben, bei der Relativen wird die die Werkzeugposition in Bezug auf den Nullpunkt deines Werkstückes angegeben.

    Zitat

    2.) Scheiß auf die Arbeitsfläche !
    Also, mal ehrlich. Wenn ich den Referenzpunkt wie in meinem Bild zu sehen auf "oben links" setze, dann das Werkstück definiere ... dann die Zeichnung lade ... und als Positionierung nicht das Werkstück sondern den Nullpunkt angeboten bekomme mit den Optionen "mittig drauf" oder "mit unterer linker Ecke auf den Nullpunkt", dann habe ich irgendwas nicht richtig verstanden, oder es ist einfach krank. (Im Moment gehe ich von letzterem aus, bis mir einer sagt, wo ich falsch liege).

    Der Reverenzpunkt steht nicht im direktem Zusammenhang mit dem Nullpunkt deiner Zeichnung.
    Er dient nur dazu deiner Software zu sagen wo deine Maschine steht, alle anderen Positionierungen richten sich nach dem Nullpunkt, nicht dem Reverenzpunkt, deshalb kannst Du den Reverenzpunkt auch auf die 4 Ecken verteilen, der Nullpunkt bleibt trotzdem unten rechts.
    Wenn du deine Datei geaden hast kannst Du mit der Orangen Schaltfläche am linken Bildschirmrand in der Mitte (Positionieren) dein Werkstück per Maßeingabe auf deiner Arbeitsfläche positionieren.
    Alternativ, wenn du nicht wiesst wo dein Werkstück liegt, kannst Du es ankratzen und über die lustigen Zieldarstellungen (z.B. X Nullpukt setzten) oben mittig entweder jeder Achse einzeln oder sogar in kombinationen relativ nullen (Werkstück Nullpunkt)

    Zitat

    Ich meine ... ich will die Zeichnung doch relativ zum Werkstück haben ... und nicht relativ zum Nullpunkt.
    Irgendwie erschliesst sich mir das nicht.
    Ergebnis : Siehe ersten Satz dieses zweiten Punktes


    3.) Start des Fräsvorganges !
    Ich clicke auf "Start" - es kommt ein Fenster mit den verschiedenen Werkzeugen usw. OK, ich clicke irgendwann nochmal auf Start und ... Also, mal ehrlich. Wer hat sich denn dieses blöde, modale Fenster da einfallen lassen ?
    Statt in dem Fenster zu bleiben, wird es geschlossen und stattdessen dieses modale ! (Also, ein autarkes Fenster, daß die Bedienung des Hauptfensters unterbindet, bis es geschlossen wird) Fenster eingeblendet, das noch nicht mal einen "Stop /Abbruch / Alles anhalten"-Knopf bietet ? Stattdessen ein güldenes Kreuz mit der Funktion "so langsam wie möglich" !

    Was ist das? Hab ich noch nicht gehabt, ausser wenn ich den Button +- angeklickt habe

    Zitat

    Den hier von EAS mitlesenden : bitte ... ich gewöhne mich ja an vieles, aber dieses Ding geht garnicht !
    Warum bleibt das grosse Fenster mit den Werkzeugen und Einstellungen nicht geöffnet, das noch um den Speedregler und eine "STOP"-Funktion ergänzt wird ? Idealerweise auch mit einer optischen Hervorhebung, mit welchem Werkzeug die Maschine grade wie weit ist ?
    (Ich bin beruflich Softwaretester und sicherlich, was Frässoftware angeht, nicht betriebsblind ... hier sehe ich jedenfalls dringend Nachholbedarf !)

    Wie gesagt scheint bei Dir rigentetwas sehr seltsdam zu sein.
    Die 3 Buttons Start, Pause und Stop sind immer verfügbar bei mir.
    Der ESC Knopf auf der Tastatur ist wie ein Not-Aus und (ich bin mir nicht sicher) die Leertaste meine ich auch.

    Zitat


    4.) Das Laden einer .dxf-Datei !
    Auch das habe ich heute end-lich hinbekommen. Ich habe also ein Rechteck der Größe 20x5cm gezeichnet und importiert, allerdings wird die von mir im CAD definierte, korrekte Größe nur dann sauber importiert wenn ich beim Import auf "Eigene" und "1" gehe.

    Dieses wird am Export deiner CAD-Software liegen.
    Wenn dort das Maß in Millimeter angegeben wird mußt du eben auf 1 (Millimeter) stellen

    Zitat

    Wobei ich mich immernoch frage, was "1" eigentlich bedeutet ? 1Meter ? 1Liter ? 1Sofa mit Springfedern

    Wird wohl Millimeter sein, bzw. das Maß welches man als Basismaß eingstellt hat (Metrisch oder Zoll)

    Zitat

    Dieselbe Frage bei der möglichen Auswahl "1mil" ? Was bedeutet das ? 1Glas Milch

    1Mil stammt aus der Leiterplattenindustrie, eine Abwandlung von Zoll, ich meine das ein Mil 0,0256Millimeter sind, bin mir aber bei dem Maß nicht 1ßß% sicher

    Zitat


    Fragen über Fragen .... die mitgelieferte Anleitung schweigt sich hier leider aus.

    Die Angabe 1/40 ist eine Ploteinheit also 1/40 Millimeter = 0,025Millimeter je Einheit
    Hast Du dir sdchon mal über einen Editor eine DXF oder PLT angesehen?
    Dort stehen da nur Koordinaten, keine Einheiten.
    Die Einheiten muß man vor der Ausgabe in der CAD Software einstellen und bei der Frässoftware auf die selbe Einheit einstellen.
    Da es einige Exoten gibt macht das Fenster mit der frei definierbaren Einheit wirklich Sinn.

    Zitat

    5.) Geschwindigkeiten !
    OK, es hat eine Weile gebraucht bis ich endlich dahintergestiegen bin, aber mittlerweile habe ich die Fräsgeschwindigeiten und auch die Eilgeschwindigkeiten soweit im Griff, daß ich sie einstellen kann.
    Was jedoch noch nicht läuft, ist das editieren der Geschwindigkeiten für die Referenzfahrt ! Bei mir kriecht die immer mit etwa 1mm/Sek. und das ist etwas nervig. Bestimmt bekomme ich das auch noch hin - wenn mir jemand hier aber schriftlich unter die Arme greifen möchte - nur zu !

    Die Geschwindigkeiten für die Reverenzfahrt kann man einstellen unter Geschwindigkeiten -> Reverenzgeschwindigkeit. Wähle den Wert klein, nach erreichen des Tasters muß die Achse gebremst werden ohne vorher auf ein Mechanisches Hindernis zu treffen. Ich referenziere z.B. mit 10mm/sec. Wenn der Tisch an der Falschen Stelle steht dauert das natürlich sehr lange, deshalb fahre ich die Maschine vor dem Abschalten nochmal reverenz und lasse den Tisch dann da stehen

    Jan, ich bin auch erst vor einem Jahr mit der CNC Geschichte angefangen, vor einem halben Jahr mit NC-Easy.
    Ich bin also auch nur NC-Easy User.
    Das Handbuch hat mich sehr weit gebracht, alles was ich hier geschreiben habe habe ich entweder aus dem Handbuch oder per learninmg by doing gelernt oder ausprobiert.
    Kann sein das das eine oder andere nicht korrekt ist, während ich dies getippt habe saß ich 3 Stockwerke höher als meine Maschine steht, so das ich es nicht mal eben ausprobieren konnte.
    Das eine oder andere wirst Du sicherlich auch schon gewusst oder gefunden haben.
    Wen Du willst könnten wir die Tage mal telefonieren während wir beide an unseren Maschinen sind und dann versuchen das eine oder andere Problem zu beheben.
    Ich hab jetzt auch keine Lust mehr das getippte noch korrektur zu lesen, also verzeih mir bitte Tippfehler.
    Gruß
    Ingo

  • @ igab


    Danke ! DAS hat doch mal geholfen - jetzt ist mir wieder einiges klarer bezüglich der ganzen Koordinaten und der absoluten und relativen Positionen. Auch das Thema mit den Importen und den Einheiten erschliesst sich mir jetzt langsam - auch wenn ich noch immer nicht verstehen kann, warum seitens EAS dazu nichts im Handbuch steht.


    Das mit diesem aufpoppenden Fenster - da muß ich wohl nochmal in die Einstellungen rein und versuchen das zu deaktivieren ... ist wirklich sehr ärgerlich dieses modale Fenster.


    Bezüglich der Referenzfahrgeschwindigkeit bin ich mir sicher, an genau der richtigen Stelle die Werte entsprechend erhöht zu haben - nur eben ohne daß die Fahrt auch wirklich schneller wurde. Ich werde da nochmal ein wenig herumprobieren.


    @ DJ-Bino


    Du bist jetzt schon der zweite der unbedingt will, daß ich mit jemandem hier telefoniere.
    Ich frag jetzt mal ganz blöd hier in die Runde : Ist das hier so Usus, daß Probleme oder Fragen nicht öffentlich innerhalb des Forums sondern ear-to-ear gelöst werden ? So nett das vielleicht ist, so unterminiert das doch den Sinn eines Forums, oder ? Der Sinn eines Forums ist doch auch, daß spätere Besucher, die vielleicht genau dieselben Probleme haben, den ganzen Sermon hier nachlesen können.
    (Ich habe selbst ein Forum im Netz - ich wüsste nicht, daß da irgendwer mit irgendwem über derartige Themen telefoniert ... geschweige denn, dazu aufgefordert wird).


    In diesem Sinne also nochmal : Danke ! ... und ... ich melde mich dann bestimmt in wenigen Tagen mit den nächsten Fragestellungen ........ schriftlich ! :D


    Grussi, Jan

  • Naja, am Telefon ist in wesentlich kürzerer Zeit wesentlich mehr zu schaffen als mit stundenlanger tipperei, das ist der einzige Hintergrund.
    Dazu kommt das man spontan auf neue Probleme eingehen kann, getippt dauert es eben länger.
    Wie auch immer, wenn du es soweit hin hast ist ja elles gut.
    Gruß
    Ingo

  • Hallo Jan,


    wegen mir musst du nicht telef. :D
    Ich habe geschrieben ich denke,.........


    Es stellte sich mir die Frage wie schnell du
    am Ziel sein willst. Da wäre dann, das Telef.
    die schnellste Möglichkeit gewesen. ;)


    Ich würde aber auch mal die Kritikpunkte einfach
    mal bei EAS anbringen. Die Haben einen sehr guten
    Support. Herr Hornbergs ist für so was offen. Eine
    andere Möglichkeit wäre noch Michael Boenigk zu
    kontaktieren das ist der Hersteller der Software.


    Bei beiden kannst du ja den Weg über E-Mail wählen
    wenn du nicht gerne telef.


    Gruß
    Dieter

    Ich repariere alles solange ganz, bis meine Frau entscheidet,
    dass wir es wegen Überreparatur wegwerfen können. :thumbsup:

  • Hallo liebe Helfer !


    eines vorweg : Ich komme langsam weiter ... und das nicht zuletzt dank eurer Hilfe ! An dieser Stelle schonmal vielen Dank !


    Heute habe ich meine ersten "Teile" gefräst - soll heissen : Ich habe Konturen gezeichnet, diese nach NcEASY übetragen und das ganze dann in Hartschaumstoff gefräst. So war ich denn in der Lage, auch nochmal die Grundeinstellungen der Fräse, die Motordaten usw. zu überprüfen. Soweit bin ich sehr zufrieden. Trotzdem sind natürlich mal wieder einige Fragen aufgetaucht - auch zum "Umfeld" von NcEASY. Ich hoffe also wieder mal auf eure Hilfe.


    1.) Meine Zeichnung habe ich mal testweise in TurboCAD 2D3D V.16 gemacht (Testversion bei IMSI runtergeladen). Layer 1 war ein Rechteck, mit 80x20mm Seitenlänge. Layer 2 waren zwei Kreise innerhalb dieses Rechtecks.
    Im NcEASY habe ich nun den Layern entsprechende Werkzeuge zugeordnet.
    Das Rechteck : 6mm Fräser, Aussen, 1mm Z-Zustellung mit 9 Wiederholungen .... so daß ich auf 10mm Frästiefe komme.
    Die Kreise : 6mm Fräser, innen, 1mm Z-Zustellung mit 3 Wiederholungen ... so daß ich auf 4mm Frästiefe komme.


    Das Ergebnis war : Das Rechteck war soweit OK. Zwar taucht der Fräser vor Anfang einer jeden Wiederholung aus dem Material aus und dann mit -1mm auf Z wieder ein (wie bekomme ich das hin, daß der Fräser einfach 10x um meine Kontur herumläuft ohne austauchen ?) ... aber die Zahl der Wiederholungen und die finale Z-Tiefe war OK.
    Die Kreise jedoch .... da mache ich offensichtlich irgendwas falsch. Ich kann nicht genau sagen auf welcher Tiefe der Fräser hier begonnen hat (ging zu schnell - und er fuhr gleich zu beginn tief ins Material) aber die finale Frästiefe war ebenfalls 10mm (und nicht 4mm, wie die Vorgabe).
    Mache ich hier irgendeinen Gedankenfehler ? Ich habe die Daten anschliessend überprüft - die waren soweit OK. Jemand eine Idee ?


    2.) Ich stelle mir grad die Frage, wie man in NcEASY definiert, daß eine ganze Tasche ausgefräst werden soll ... oder ist dies innerhalb des CAD zu definieren ? Wenn dies so ist ... wie ist das beispielsweise bei TurboCAD zu erledigen ? (Die Software gefällt mir soweit ganz gut - ich spiele mit dem Gedanken, mir eine 2D-Version V.15 zuzulegen, die gibt´s bei eBay ja recht günstig).


    tja, das war´s schon für heute ... ich finde, ich "bessere" mich langsam :D


    Jan