Triple Beast und WINPC-NC USB

  • Ich hätte da mal auch eine frage


    zur Triple Beast, mir ist aufgefallen (wenigsten bei mir) wenn ich
    .nc Dateien ablaufen lasse ist alles OK.
    Selbst wenn der Job 8 Stunden dauert.
    Bei .plt Dateien passiert es regelmäßig das die Steuerung aussteigt
    mit der Fehlermeldung - Echtzeit Modul Blockiert - ist ärgerlich weil
    ich meistens .plt Dateien verwende zum Platinenfräsen.
    Ich verwende Sprint Layout und die Ausgabe ist nun mal .plt mit
    der Software.
    Hab schon einiges in die Tonne werfen müssen.


    Ernst der Wusl
    -------------------------------------------------------------------------------
    Erfahrungen sind die Samenkörner
    aus denen die Weisheit Emporwächst

  • Hallo,
    ich glaube nicht, dass das was mit der TripleBeast zu tun hat.
    Das Problem wird bei WINPC-NC liegen. Plt-Dateien haben ja oft eine entsprechende Größe dadurch bedingt, dass keine Kreise ausgegeben werden. Diese werden in viele kleine Segmente zerlegt. Daraus resultiert dann eine entprechend große Anzahl von Befehlen um den Kreis abzufahren. Bei entsprechender Fräsgeschwindigkeit steigt dann auf Grund der großen Menge von abzufahrenden Koordinaten irgendwas aus. Wahrscheinlich hat WINPC-NC damit ein Problem --> Speicherüberlauf, Vorrang des Echtzeitsystems für die Bahnsteuerung wird dadurch gestört. Das ist aber Kaffeesatzleserei von mir. Um Genaues zu erfahren sollte man sich mit dem Entwickler Herrn Lewetz in Verbindung setzen. Der antwortet normalerweise sehr schnell.
    Abhilfe könnte ev. die Verwendung von eckigen Pad's schaffen.


    Gruß
    Wilfried

  • Hallo Wilfried


    ich möchte keinen von beiden schuld geben, hatte eh vor mir
    mal Mach3 zu kaufen und dann kann ja auch sehen ob es damit
    auch passiert.
    Die .nc Dateien sind auch nicht ohne mit 873 000 Zeilen = 6,8MB
    Evt. bekomme ich mal von einem User in der nähe eine Steuerung
    zum Testen.


    Gruß
    Ernst der Wusl

  • Hallo Ernst,


    Ich denke Wilfried hat hier shcon sehr schön die Wharscheinlcihe Fehlerursache beschrieben. Du kannst einmal ncoh einen anderen USB-Port des Rechners versuchen und/oder ein besser geschirmtes USB-Kabel.


    Bevor Du auf MACH3 umsteigst, bedenke aber das MACH 3 keine PLT Dateien abarbeiten kann 8|


    Wenn Du nur G-Code Daten hättest, würde ich Dir auch mal einen der EdingCNC (Ehemals USBCNC) zum Testen anbieten. Aber auch EdingCNC kennt nur G-Code.



    Grüsse


    Roy

    [url=http://www.sorotec.de][img]http://www.cnc-area.de/Firma/sorotec/sorotec-logo_300.jpg[/img][/url] BZT-Süddeutschland
  • Hallo Roy,


    besten Dank für das Angebot, werde mal versuchen die Sache mit dem USB Kabel.
    Und einen anderen PC bzw. Laptop nur für die Software.


    Wäre halt schön gewesen wenn das Modul nicht in einem Plastikgehäuse verbaut
    wäre, könnte man noch zusätzlich auf masseausgleichpontial legen.


    Eine eigene Versorgungsspannung würde evt. die USB Schnittstelle entlasten.
    Hab schon bei USB Sticks Festgestellt das einige bei verschieden Rechnern
    nicht erkannt werden, aber nicht wegen Treiber sondern Stromaufnahme.


    Würd halt 10 Euronen mehr kosten spielt aber in der Gesamtsumme bei unserem
    CNC Hobby keine große Rolle. Das Modul hab ich schon in ALU Folie eingepackt.
    Nur so mal meine gedankengänge.
    Ich würde Mach3 auf eine anderen Rechner laufen lassen und mit einem
    Parallelswitch umschalten.



    Ernst der Wusl


    -------------------------------------------------------------------------------


    Erfahrungen sind die Samenkörner


    aus denen die Weisheit Emporwächst

  • TripleBeast und WINPC-NC USB


    Ich muss nun doch noch mal das Thema ansprechen, Es ist Unmöglich einen Job durch zu führen

    mit .plt Dateien ohne das nach 3 – 4 Bohrungen der Abbruch erfolgt STOPP SIGNAL ERKANNT.


    Ich habe alles mögliche gemacht, in Win10 alles mit den USB Einstellungen das nichts Bremst.

    USB Modul in Alu Folie gewickelt alle Leitungen mit Ferriten ab geblockt, aber kein Erfolg.


    Gestern 5 Stunden für eine Europa Karte große Platine (100x160mm) mit ein paar Leiterbahnen und ca. 130 Bohrungen zu erstellen 6 Bohrungen gingen verloren wurden einfach nicht gemacht obwohl

    im Fräs PGM drin waren.


    Bei genauen Beobachtungen trat der Fehler immer auf PEN UP wenn der Fräser auf Sicherheitshöhe fährt.


    Steuerung ausschalten wieder einschalten Referenzfahrt und dann bei Zeile im PGM weiter machen.


    Aber das ca. 50 mal das Nervt nur noch.


    Wer weiss noch Rat.

  • hallo Ernst,

    bei meiner ersten Eigenbau CNC hatte ich für die Endlagenschalter 5Volt gehabt. Diese elektronik hat recht empfindlich auf EMV reagiert.

    Quelle der Störungen war die Frässpindel(Kress) selber oder auch der Staubsauger.


    Später bei der neuen CNC hatte ich dann starke Störungen von dem Umformer für die HF Spindel. Da half dann eine saubere Abschirmung und ein Enstörfilter. Zur Sicherheit habe ich für die Steuerung dann noch eine andere Phase genommen.


    Zu deinem Problem, es deutet in der Tat auf ein Problem mit dem USB hin. Eventuell hat dein USB Ausgang nur eine magere Spannung von 3,5 - 4Volt Notebook?

    Abhilfe könnte die Verwendung eines älteren gebrauchten PC bringen. Die haben zumindest die 5Volt. Zum Testen könntest du auch die Arbeitsbereichs-Überwachung ausschalten oder größer einstellen.


    Bei mir traten solche Fehler aber mit parralleler Schnittstelle auf. USB scheint mir da deutlich empfindlicher zu sein.

  • Ich kenne das Problem von meinem 3D-Drucker mit dem Rumba-Board her. Meiner Erfahrung nach kann ich sagen, dass der Durchmesser allein nichts aussagt.

    Das Problem ist heute bloß wo bekommt man gute Qualität her und wie erkennt man als Laie die gute Qualität. Von den Händlern wird ja viel versprochen.

  • Hallo Wilfried,

    die meisten USB Kabel sind minderwertig und sollen zum Laden und zur Datenübertragung taugen. Beides jedoch nur halbherzig.


    • 1 Ferritkern oder besser zwei!
    • Stärke der Kupferadern gemäß USB-Norm: AWG28 + AWG24
    • doppelt abgeschirmt mit Folien- und Gefechtschirm (65% Abdeckung)
    • geschirmte Steckverbinder mit angegossene Zugentlasung


    Das wären Mindestanforderungen wenn Daten übertragen werde sollen. Nach Oben ist da noch Luft.

    Für die CNC Steuerung sollte das Beste gerade gut genug sein!

    Da gibt man viel Geld für eine Steuerung aus und kauft sich für 2 € ein USB Kabel,,,,,,,,

    Dazu dann noch so einen HF Umformer für die Spindel ohne jegliche EMV Filter .... Nicht abgeschirmte Kabel für die Spindel und Endlagenschalter.

    Das ganze in Verbindung mit Schaltnetzteilen ist auf Kurzwelle noch auf 500m entfernung zu zu Empfangen.


    Dann stellt man im Forum die Frage, "Habe Schrittverluste, woran könnte es liegen?"


    Es gibt natürlich noch andere Ursachen, aber diese Dinge zur Abschirmung und Vermeidung von elektronischen Störungen sollten zuerst mal abgestellt werden.

    Und zwar schon beim Bau. Das spart Geld und Zeit.

  • Hallo,


    bei "Stopp Signal erkannt" würde ich das USB Kabel als eher unwahrscheinliche Fehlerquelle ansehen (auch wenn es allgemein für 90% der Probleme bei USB Steuerungen verantwortlich ist.)


    Klemme mal einen 100nF Kondensator mit in die beiden Kontakte für den E-Stop des TripleBeast.

    Und prüfe bei der Gelegenheit ob da ein Wackelkontakt ist oder die Schrauben nur locker angezogen sind.


    Falls es kein Wackelkontakt ist und der Kondensator hilft hast du allerdings irgendwo definitiv einen erheblichen "Störsender".


    Christian

  • hallo Wilfried,

    nur ein Beispiel

    https://www.partsdata.de/usb-2…kern-premium-qualitaet-3m


    Christian_Knuell

    Bei mir war damals der Umformer aus China die Hauptursache. An zweiter Stelle stand dann das Schaltnetzteil für die Stepper.


    Bei dem Schaltnetzteil habe primär ein zusätzliches Netzfilter, und Sekundär Plus und Minus Leitungen jeweils getrennt mit 10 Windungen durch einen je einen Ferritring, die Störungen beruhigen können.


    Das gemeine bei diesen Störungen ist ja, dass es meistens sogar noch gut geht, dann tauchen Fehler nach einiger Zeit au,f und man meint, da muss etwas defekt sein oder die Software macht Fehler. Oft ist es ja nicht reproduzierbar. Besser ist es von vorn herein alles sauber aufzubauen.


    Wenn man dann die Störungen sichtbar macht mit Scope oder Spectrumanalyser wundert man sich, was da so alles an Signalen auf den Leitungen und in der Luft ist.

  • Vielen Dank für die Vielen Meldungen,


    das USB Kabel ist mit Geliefert worden zu der USB Box, ich Blocke alle Kabel wenn möglich mit Hochwertigen

    Klappferriten ab bei denen der AL Wert angegeben ist.

    Stecker u. Buchsen sind sind HAN bzw. Harting verbindungen verschraubt.


    Die Kruxs bei der ganzen sache ist die, der Fehler tritt immer NUR mit HPGL bzw. .plt Dateien auf .

    .nc DIN/ISO ISEL usw. Dateien können Tage oder wochen laufen ohne Ärger zu machen.


    Habe jetzt vom Herrn Lewetz einen vorschlag erhalten den ich noch Prüfen muss, hab nur pausieren

    müssen eine Influenza A hat mich flach gelegt aber vom feinsten trotz 4 Fach Schutzimpfung.


    Werde diese woche noch pausieren müssen aber dann wird getestet.


    Ernst Euer Wusl

  • hallo Wusl,

    dann kannst du ja andere Ursachen ausschließen und der H. Lewetz wird gemeinsam mit Dir das Problem einkreisen können.

    Er hat mir früher auch immer recht schnell geholfen,


    Ich hatte nur an Störungen gedacht, weil die Laufzeit bei deinen großen PLT Dateien ja länger ist, und somit auch die mögliche Störung eher mal auftritt.

    Jedenfalls sollte man alles andere zuerst ausschließen, bevor man an der Software runschraubt.


    Viel Erfolg