Starthilfe bei meiner eigenbau billig-Fräse (Problem mit Schrittmotoren)

  • Das mit dem Schutzleiter ist leider oft so bei Chinaware. Da geht man davon aus, dass diese open-frame Geräte im Schaltschrank verbaut werden und eine Extra Leitung zum GND-Punkt bekommen, von ihrer GND-Anschlussklemme. Das könntest Du einfach nachrüsten, nimm eine passende Schraube für das Metallgehäuse (da sind ja meistens an einer Seit und unten Einpressmuttern drin) und eine U-Scheibe und eine Zahnscheibe und dann ein Kabel von GND auf diesen "GND-Punkt" Wichtig wäre für die Schirmungsqualität, dass dies der neue GND-Punkt für die Schirmung/Zusammenführung der GND-Adern der Steuerung/Schirmungen usw. wird. ODer ein anderer Sternpunkt, wo diese zusammenlaufen, dann ein Extra Kabel vom NT dort hin.


    Danke für die Antwort und die Empfehlungen.

    Sorry, ich habe das mit dem Netzteil noch nicht ganz verstanden. Ich habe am Netzteil unter anderem –V bei dem Output Anschlüssen und so ein Erdungssymbol bei den 230V Input Anschlüssen. Wo soll ich jetzt das Gehäuse und wo die Schirmung anschließen?

  • Hallo Irgendjemand,

    Der Erdungsanschluss PE (grün-gelb) des NT sollte an den Erdungspunkt, also einen Punkt am Metallgehäuse, in den es verbaut wird kommen. Dicht am Netzanschluss, wo auch der PE von "außen" aufgelegt wird. Dieser darf dann auch der Sternpunkt bei einer Masse-Sternverdrahtung) sein. Müsste aber nicht zwingend so. Es können auch zwei Punkte sein, einmal PE und einmal der Stern-Massepunkt. Am Stern-Massepunkt laufen dann alle GND-Leitungen der Endstufen, die Schirmungen und andere GNDs zusammen. Und eine Leitung geht dann zum PE. Aber Vorsicht, daß nicht andere Schirmungen schon woanders auf PE liegen, dann hast Du Brummschleifen. Das -V darf dann als Masse-Anbindung auf den Sternpunkt Masse gelegt werden. Damit ist die NT-Masse für alle anderen auf kürzestem Wege verfügbar.


    VG Hanno

  • Danke für die Hilfe, ich habe jetzt das 24V Netzteil eingebaut und schon den einen oder anderen Fräsversuch gestartet.

    Leider habe ich immer noch einige Probleme:

    - Ich habe Probleme mit skipping. Mein Y-Achsen Schrittmotor ist beim letzten Fräsversuch bei einer Bewegung durch die Luft (Verbindung zwischen zwei Löchern im Fräsvorgang) einfach stehen geblieben. Er bewegte sich mit voller Geschwindigkeit. Vielleicht hat sich irgendetwas verklemmt oder so (Ich hab eigentlich 24V und akzeptable Temperaturen der Treiberplatinen), jedenfalls hat es dazu geführt, dass der Rest, der noch gefräst werden musste, verschoben war.

    - Und auch davor hat meine Fräse an einer Stelle plötzlich neben der vorher gefrästen Spur gefräst.

    - Bei einem anderen Fräsversuch hatte ich das Problem, dass das letzte zu fräsende Loch (auch beim zweiten Versuch) an der falschen Stelle war. Ich schätze dass die Geschwindigkeit, mit der sich der Motor gedreht hat, irgendwie für Interferenzen oder Vibrationen oder so gesorgt hat. Das Loch war in beiden Fällen an der gleichen, falschen Stelle. Die Strecke auf einer Achse war ca. 50% zu kurz. Der G-Code wird im universal g-code sender richtig angezeigt.

    - In UGS ist mir noch etwas anderes aufgefallen: manchmal sieht das ganze so aus:

    >>> G1X-1.536Y22.529

    >>> G3Y21.971I0.279J-0.279

    ok

    ok

    anstatt so:

    >>> G1X16.67Y3.765

    ok

    >>> G3X17.228I0.279J0.279

    ok

    >>> G1X34.32Y20.857

    ok

    ist das ein Problem?

  • Hallo,


    verwendest du eines dieser Schrittmotorshields mit den winzigen ca. 10x20mm großen Endstufenplatinchen?

    Falls ja: heb es für einen kleinen 3D Drucker auf oder werf es direkt in den Müll.


    Die Treiberchips darauf sind an und für sich gut - und für kleine 3D Drucker mit schwachen Motoren ist dagegen auch gar nicht viel einzuwenden.

    Nur sind die Kühlflächen dieser Winzlingsplatinchen für den Nennstrom der Chips völlig unterdimensioniert - da helfen auch die aufpappbaren Kühlkörperchen nicht viel.


    Die Chips haben einen integrierten Überhitzungsschutz. Gute Sache, denn sonst würden sie gleich reihenweise sterben, allerdings springt der nur für einen Sekundenbruchteil rein, bringt den Motor zum stehen und dann ist das Teil mangels thermischer Kapazität schon wieder so weit abgekühlt dass der Schutz wieder deaktiviert wird und der Motor erneut Strom bekommt -> ganz kurze Aussetzer die einen zum Wahnsinn treiben können wenn man nicht weiss warum.


    Ich hatte mir zum Spaß mal so ein Shield aus China bestellt - viel mehr als 1A Dauerstrom konnte man aus den Teilen nicht rausquetschen ohne Probleme zu bekommen.


    Bei Endstufen lohnt sich sparen nicht. So ca. 50 Euro je Achse sollte man einkalkulieren, dann hat man dauerhaft Freude daran (z.B. original Leadshine Endstufen, allerdings nicht deren billigen Clone).


    Christian

  • Danke für den Hinweis, ich verwende tatsächlich diese kleinen Treiberplatinchen mit A4988 Chips. Aber die Kühlkörper erreichen nur so um die 30°C, wird denen da wirklich schon zu heiß? Außerdem erklärt das meiner Meinung nach noch nicht die Verschiebung des Lochs im 3. Punkt.

  • Hallo,


    die Verschiebung des Lochs ist in der Regel eine Folge der Schrittverluste durch die kurzen Stillstände.


    30° sind nicht viel, allerdings werden diese Chips normalerweise auch nicht von oben gekühlt, sondern hauptsächlich durch die Kupferfläche der Platine darunter - deswegen funktioniert das auch mit diesen Platinchen so schlecht (und nochmal schlechter wenn es die Billigkopien aus China sind die keine vernünftigen thermal Vias unter dem Chip haben) .

    Dazu kommt noch dass die Kühlkörper oft irgendwo an Pins oder dem Minipoti aufliegen und damit gar keinen richtigen Flächenkontakt mit dem Chip haben.


    Aus meiner persönlichen Sicht liegt diesen Platinen eine generell fragwürdige Konstruktionsentscheidung zugrunde. Die Platine hat gerade mal 3cm² Gesamtfläche. Ich hab jetzt nicht die Mindestanforderungen im Kopf, für den DRV8825 (einen ähnlichen Chip) steht allerdings z.B. 20cm² Kühlfläche als Empfehlung im Datenblatt. Das ist also nicht knapp auf Kante genäht, sondern wirklich komplett daneben.

    Entsprechend spuckt Google für "a4988 overheating" auch stolze 40000 Ergebnisse aus.


    Christian

  • Hallo Irgendjemand,

    ein gutes neues Jahr!

    Ich bin da komplett bei Christian. Das hatte ich aber in meinen Anfangsposts auch schon zu bedenken gegeben. Die Winzi-Treiberchen sind eben für 3D-Drucker und wenig Kräfte konzipert und selbst da versagen sie reihenweise.

    Die Kühlung und Notabschaltung ist das eine Problem, die kurzzeitige Überhitzung des Chips kannst Du nicht messen, die kommt verzögert und macht keine hohen plötzlichen Anstiege (nur auf dem Chip selbst) aus. Aber der Motor setzt aus und du hast eben Schrittverluste. "Unerklärlich" - nein. Überlastung.


    Die Mechanik ist weiterhin das Problem. In der Konstruktion stecken so viele Unwägbarkeiten und Reibung mit den Kugellagerführungen, den Gewindestangen, der Ausrichtung, Lagerung, dem Schwingen der Spindeln und und - da müsste man die Motoren deutlich überdimensionieren damit die das alles wegbügeln. Und da kommen eigentlich nur Nema23 in Frage, mind 2Nm plus passende Endstufen und Netzteil Und schon bist Du bei einem Upgrade von 250-300€ wo man sich fragen muss ob das für dieses Projekt lohnt. Abgesehen vom Gewicht des Portals, das damit aufs Doppelte und mehr anwächst und das Problem vergrößert. Mit Optimieren ist da nichts mehr.

    Oder ob man das nicht als Lehrgeld betrachtet und neu baut für wenig mehr. Das hängt dann von Deiner Freude und Portemonnaie ab. Neubau kostet mehr, lohnt aber im Ergebnis. Schau Dir mal eine KIM oder C't Fräse an. Alles unter 1k machbar. Alles darunter ist - meine meinung - verzockt, weil es einfach nicht funktioniert. So schade das ist.

    Viele Grüße, Hanno

  • Hallo,

    um die Pololu's loszuwerden, empfehle ich Poludapter und da macht Du vernünftige Endstufen dran. Das geht wunderbar und funktioniert sauber. Die Poludapter kannst Du zur Not weglassen und die Signale über Stekleisten abgreifen. Das ist zumindest eine Lösung um Schrittverluste zu vermeiden. Die Endstufen kannst Du später auch einsetzen, wenn Du Dir eine richtige Fräse baust.


    Gruß Klaus


    https://youprintin3d.de/upgradekits/80/poludapter.html