Brauche mal ein wenig onside Hilfe

  • Hi,


    wer von euch wohnt im Reihn Main Gebiet und könnte mir Helfen meine Z1000 mit edding (sorotec) Steurrung in Betrieb zu nehmen. Fahrkosten und ein kleines Entgeld (Hobby) erstatte ich. Ich kommed a irgend wie nicht weiter. Maschine steht in Dietzenbach.


    Gruß Thorsten

  • Hi Klaus


    Ja du hast recht mehr Infos wäre wohl besser.

    Also hier die Infos uns mein aktuelles Problem. Als Software verwende ich eding 4.03 V5-A4-E. So jetzt zu meine, aktuellen Problem. Wenn ich das richtig verstanden habe dann musss ich beim ersten Mal die Fräse auf die Referenzschalter X, Y und Z stellen das trage ich die daten der Fräse unter Einstellung ein und drücken F2 und dann F8. Soweit so gut zu diesem Zeitpunkt geht auch alles. Nur wenn ich jetzt die Maschine verfahre und dann ausschalten dann will sie wieder eine referenzzierung also wieder F2 und F8 nur dann stellt sie die Achsen auf der Position auf 0 wo die Maschine gerade ist. Ich will aber sowas wie eine Referenzfahrt. Das sie ihren Nullpunkt wieder findet, oder liege ich da total falsch.


    Gruß Thorsten

  • Ich habe es bei mir so eingestellt das die Achsen in Plusrichtung fahren und die Ref.-Schalter am Maschinennullpunkt angebracht sind. Die Laufrichtung der Achsen sind bei mir mit einem Minus vor der Stepzahl, was eine Invertierung der Achsenfahrtrichtung zur Folge hat. Die hätte ich auch mit der Umpolung der Motoren an der Steuerung machen können, so war es aber einfacher. Die Ref.-Schalter sind normalerweise an der Seit der Achse angebracht, an der der Motor sitzt. Das muss auch nicht so gemacht werden. Ich habe es auch bei einer Achse ändern müssen, da ich beim Aufbau der Maschine das Portal anders herum auf der Maschine vorgesehen hatte, als ich es letztendlich wirklich gebraucht habe. Daher ist der Schalter anderes. Vom Schalter weg läuft die Maschine immer in Plusrichtung. Damit wird dann auch das Koordinatensystem der Maschine festgelegt. Ist die Software dann so eingestellt, wird durch das Setzen des Werkstücknullpunktest dann festgesetzt wie die Anzeige der Koordinaten der Achsen angezeigt wird. Ist der Werkstücknullpunkt vorne links und der Maschinennullpunkt auch, werden immer positive Werte für X und Y in der Anzeige angezeigt und bei Z ist das abhängig von der Definition des Nullpunktes Oberkante Werkstück oder Unterkante Werkstück. Die Fahrrichtung bei der Referenzfahrt wir entsprechend durch den Wert in Ref.-Vorschub eingestellt und je nach Vorzeichen wird die Referenzfahrt mit einem Minus invertiert. Da aber keine Informationen ( ein Bild sagt mehr als tausend Worte :) ) dazu von Deiner Seite vorliegen, kann ich das für Deine Maschine natürlich nicht beurteilen.

  • So,


    habe den Fehler mit Roy von Sorotec gefunden. Wie gesagt der Depp sitzt immer davor. Die cnc-Step hat zwar zwei Stepper auf der X Achse aber nur einen Endtaster und damit muss man ein Y Ethernet Kabel zum anschluss der Endstufen verwenden und nicht wie ich alle 4 auf das breakoutboard stecken.


    Gruß Thorsten

  • Siehste, ich muss ehrlich sagen das du es uns sehr schwer gemacht hast an einer Lösung zu arbeiten. Du hast die Bitte nach detailierten Informationen völlig ignoriert und nur gschrieben das du EdingCNC verwendest. Was ich davon halte schreibe ich hier nicht und zukünftig werde ich in solchen Fällen die Anfragen ignorieren.

    Trotzdem gut für dich, das die Maschine jetzt läuft.

  • Ja du hast recht, Sorry aber alles Neuling ist dir nicht unbedingt klar was jetzt relefant ist und was nicht. Werde versuchen mich zu bessern. Ich habe mir jetzt zwar ein Y Ethernet Kabel bestellt aber ob das noch vor Wiehnachten kommet liegt in den Sternen. Kann ich den Endschalter auch von X1 brücken nach X2?


    Gruß Thorsten

  • Hallo Thorsten,

    ganz ehrlich gesagt weiß ich das nicht, da Du nicht beschreibst wie Du die Schalter angeschlossen hast. Notwendige Informationen zur Schaltung Deiner Maschine fehlen und warum Du an einer Achse zwei Referenzschalter verwendest, erschließt sich mir nicht! Auch wenn 2 Motoren und 2 Spindeln für die Achse notwendig sind, wird diese als eine Achse betrachtet. Schon garnicht wenn Du das Y-Kabel für die beiden Endstufen eingebaut hast, macht das für mich gar keinen Sinn mehr.

    Ebenso würde es Sinn machen die beiden Achsen mechanisch zu koppeln, damit das Portal im Winkel bleibt, falls es auf einer der Achsen Schrittverluste geben sollte. Welcher Schaltertyp NO oder NC verwendest Du? Mechanische oder induktive Endschalter? Wie sind die Schalter jetzt am Breakoutboard angeschlossen? Welches Breakoutboard verwendest Du?


    Gruß Klaus

  • Sorry Klaus,

    Ich habe noch kein YKabel das ist in der Post hatte ich schon erwäht. ja ich habe zwei Motoren an der X Achse und ich habe auch zwei Endstufen. beide Endstufen gegen einzeln auf mein Breakoutboard. und genau hier liegt der Fehler ich habe aktuell nur eine Endschalten Eding will aber in diesem Fall zwei haben je eine pro Kugelumlaufspinfdel. Nun war meine fragen da das Y kabel ja noch ion der Post ob ich den Endschalter von der einen Achse einfach an beide Eingänge auf dem Brackoutbord anschliessen kann.


    Gruß Thorsten

  • Warte bis das Y-Kabel da ist. Im Moment wùrde das dann im Slavemodus arbeiten und da brauchst Du dann den Ref-schalter. Ich habe das schon mit dem Y- Kabel gemacht, brauche das an meiner jetzigen Maschine nicht. Ich kenn Dein Breakohrboard auch nicht, das verschweigst Du ja immer noch konsequent. 😀

  • Die Steuerung kann an diverse Breakoutboards angeschlossen werden. Das ein SimpleBOB verwendet wird, kann daher nicht direkt vermutet werden. Es gibt natürlich noch das Interface Pro, was schon wieder etwas anders am Eding-Controller angeschlossen wird und dazu die Anpassungsplatine benötigt. Das Einzige was auf eins der beiden Boards schließen lies, war der Y-Adapter von Roy. Das funktioniert nur an Boards mit den Netzwerkverbindern. Ich bin ganz ehrlich und habe bewußt auf den fehlenden Angaben rumgeritten, da es wirklich mühsam ist so zu helfen. Für Dich als Anfänger auch nicht einfach eine Frage vernünftig zu formulieren. Das verstehe ich aus eigener Erfahrung. Nur solltest Du dann auf gestellte Fragen auch eingehen und das hat mich in Deinem Fall echt sauer gemacht. Einfach lesen was da steht und dann ein paar Fotos posten. Da erklärt sich so manches von selbst. Dann gibt es auch noch den Begriff "RTFM" (Read the fucking Manual). In der Bedienungsanleitung steht das alles drin und wenn das nicht verstanden wird, wird gefragt. Schwarmintelligenz funktioniert auch nur auf Basis von Informationen. In anderen Foren und vor allem in Facebookgruppen habe ich das in den letzten Wochen verschärft empfunden und daher reagiere ich da im Moment etwas allergisch. Nach den Infos aus der Anleitung muss Deine Maschine auch so funktionieren wie Du sie angeschlossen hast! Die Slave-Achse von X an den A-Port und in den Einstellungen von EdingCNC die Slave-Achse definieren. Die Achse dann über 2 Endschalter zu Referenzieren ist dann wieder ein anderes Thema. Damit habe ich mich noch nie beschäftigt, da ich solch einen Aufbau bisher mit dem Y-Adapter gemacht hatte. Wenn die Schalter nicht genau am selben Punkt schalten, kann es zum Verzug des Portals kommen. Das kann bei bestimmten Maschinenaufbauten gut sein, bei einer Fräse würde ich das so nicht machen. Wie ich geschrieben hatte, ist dann eine mechanische Kopplung der Spindeln eher anzustreben. Auch wäre es möglich die beiden Spindeln mit einem Motor anzutreiben.

    Dann hoffen wir, dass der Adapter schnell kommt und Du weitermachen kannst


    Gruß Klaus