Probleme mit Skalierung bei Übergabe von Estlcam zu Mach3

  • Hallo zusammen,


    entschuldigung erstmal falls ich den falschen Themenordner gewählt haben sollte - wie man sieht bin ich noch neu hier :saint:


    Ich habe mir vor geraumer Zeit eine gebrauchte Portalfräse gekauft. Sie läuft auch - nachdem ich mich mit externen vs. onboard LPT-Problematiken rumgeärgert habe - ohne Probleme an. Der Verkäufer hat vor mir im Prinzip die gleiche Programmkette genutzt: Zeichnung in Autocad/Catia/Vwx... > Werkzeugzuweisung und GCode erstellen in Estlcam > Fräsprogramm in Mach3 abspulen .. so weit, so gut.


    Ich habe mir von ihm alle Mach3-Voreinstellungen abfotografiert und 1:1 übernommen - beide nutzten Triple Beast. Seine Modelle wurden alle maßstabsgetreu gefräst; bei mir kommen alle Programme ca. um das 1,6 fache skaliert heraus.


    Hat jemand eine Idee woran das liegen kann?


  • Hallo ZehAennZeh (hst du auch einen Namen??),

    Mach3 fräst doch alles, was im G-Code steht ! Wenn die Skalierung nicht stimmt, so kann man das doch in Mach3 wunderbar einstellen. Ist dir denn überhaupt bekannt, wie das geht ? Wenn man mit Mach3 arbeiten möchte, muß man in dieses Programm auch einmal ein wenig einarbeiten. Dazu gibt es auch Handbücher, wo alles ganz genau beschrieben ist.


    Gruß
    Immo

  • Hallo,

    was meinst du damit:

    Zitat


    Ich habe mir von ihm alle Mach3-Voreinstellungen abfotografiert und 1:1 übernommen - beide nutzten Triple Beast. Seine Modelle wurden alle maßstabsgetreu gefräst; bei mir kommen alle Programme ca. um das 1,6 fache skaliert heraus

    Hast du auch seinen G-Code übernommen und diesen gefräst oder hast du den G-Code selbst mit ESTL-Cam generiert? Wenn selbst generiert, dann musst du den Fehler in ESTL-Cam suche. Wie Immo schon geschrieben hat, arbeitet Mach3 den G-Code einfach nur ab.

    Eine Skalierung kannst du im G-Code finden. Such mal nach dem Befehl G50/G51. Ist aber unwahrscheinlich das der enthalten ist. Du kannst in Mach3 die Achsen skalieren (Scale)



    Und lass dich nicht durch erste Rückschläge dazu verleiten alles auf Mach3 zu schieben und das System zu wechseln. Mach3 ist ein über Jahre erprobtes und ausgereiftes Programm. Es bietet viele Möglichkeiten wovon andere Programme nur träumen können. Leg dir möglichst einen deutschen Sceenset zu. Die dort hinterlegten Macros funktionieren in der Regel.

    Es ist noch kein Meister vom Himmel gefallen. Auch ich merke das oft bei mir, dass das Problem fast immer vor dem Computer (Fräse) sitzt.


    Gruß

  • Hallo immo & Wilfried,


    besten Dank für die Rückmeldungen.


    Ich meinte mit der 1:1-Übernahme, dass ich alle Voreinstellungen für die Ports, die Achsparameter, etc. in Mach3 beim Vorbesitzer abfotografiert habe, um diese zuhause zu übernehmen. In der Tat habe ich aber nicht das gleiche Programm wie der Vorbesitzer gefräst sondern nur eigene Schriftzüge und Bilder. Dabei taucht dann das Problem auf. In EstlCam habe ich logischerweise Einheit=mm eingestellt - in AutoCad ebenso. Deshalb dachte ich, dass in Mach3 irgendwo ein Parameter falsch eingestellt ist und ...

    Wenn die Skalierung nicht stimmt, so kann man das doch in Mach3 wunderbar einstellen. Ist dir denn überhaupt bekannt, wie das geht ?

    ... nein, ich weiss nicht genau, wo/wie das geht. Deshalb habe ich mich u.a. hier angemeldet.


    Wenn man mit Mach3 arbeiten möchte, muß man in dieses Programm auch einmal ein wenig einarbeiten. Dazu gibt es auch Handbücher, wo alles ganz genau beschrieben ist.

    Solltest du einen Download-Link zu einem Handbuch - egal ob deutsch oder englisch - haben, so wäre ich dir sehr dankbar.



    Wilfried, bisher stehen die Achsen-Scales auch auf 1. Jedes mal wenn ich ein Programm lade muss ich (bisher noch) neu einnullen - ich bastele gerade an MNP und einem Referenzpunkt für Werkzeugwechsel. Einen Probe habe ich mir bereits organisiert. Ich bin auch keineswegs entmutigt was Mach3 angeht - es ist nur alles noch etwas neu und ich bin eigentlich nur mit WoodWOP und IMAWop vertraut gewesen bis dato :)


    Schöne Grüße aus Bielefeld,

    Joe

  • Hallo,

    du solltest uns mal die Mach-Version nennen die du gerade verwendest, dann man auch gezielter antworten. Die Versionen unterscheiden sich oft in den Macros, die für bestimmte Funktionen zuständig sind. Die Handbücher gibt es in deutscher Sprache bei den entsprechenden Händlern. Englische Handbücher gibt es bei Artsoft oder bemühe mal Google. Die Handbücher sollten zur entsprechenden Version passen, sonst ist das nicht so einfach.

    Wenn du einen ESS verwendest wäre das auch gut zu wissen.

  • Hallo Joe,


    Du schriebst, daß Deine gefräste Date nicht im korrekten Maßstab gefräst wurde und glaubst, daß es an den Einstellungen von Mach3 liegen könnte. Ich hatte Dir ja schon etwas dazu geschrieben, daß Mach3 grundsätzlich den G-Code abarbeitet, den Du geladen hast und genau das tut, was im G-Code steht. Wenn jetzt der Maßstab nicht stimmt, solltest Du als erstes einmal herausfinden, ob Deine Maschine auch eine korrekte Länge fräst, welche Du im G-Code eingibst. Dazu fährst Du manuell irgend eine günstige Position z.B. der X-Achse an und nullst diese Position. Dann gibst Du in der MDI-Zeide folgendes ein: G1 X100 F300 und bestätigst mit ENTER. Daraufhin wird die X-Achse genau 100 mm in positiver Richtung mit einer Geschwindigkeit von 300 mm/min verfahren und dann stoppen. Jetzt brauchst Du nur noch exakt nachmessen, ob die X-Achse auch genau 100 mm verfahren ist. Sollte das der Fall sein, ist in Mach3 alles korrekt eingestellt und das Problem bei der G-Code- Erstellung zu suchen.

    Was ein Handbuch betrifft, so gibt es ein solches für meine deutsche Oberfläche, wobei ich natürlich nicht weiß, ob du sie benutzt. Falls ja, so gibt es das leider nicht bei mir als kostenlosen Download, denn dafür war das zu viel Arbeit. Falls Du dennoch daran interessiert sein solltest, kannst Du Dich natürlich gerne an mich wenden. Daten findest Du auf meiner Internetseite.


    Weiterhin viel Erfolg

    Immo